# CVE-2017-9735: Jetty vulnerable to exposure of sensitive information due to observable discrepancy

> Remote attackers can exploit a timing channel in Jetty's password verification to infer correct passwords and gain unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-BA58800, DEBIAN-CVE-2017-9735, DLA-1020-1, DLA-1021-1, GHSA-wfcc-pff6-rgc5, MGASA-2017-0277, UBUNTU-CVE-2017-9735

## What is CVE-2017-9735?

CVE-2017-9735 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jetty through 9.4.x is prone to a timing channel in util/security/Password.java, which makes it easier for remote attackers to obtain access by observing elapsed times before rejection of incorrect passwords.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2017-9735?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.22.v20170606 |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.22.v20170606 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.20.v20170531 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.20.v20170531 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.6.v20170531 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.6.v20170531 |

Products: Debian Debian Linux, Eclipse Jetty, Oracle Communications Cloud Native Core Policy, Oracle Enterprise Manager Base Platform, Oracle Hospitality Guest Access, Oracle Rest Data Services, Oracle Retail Xstore Point of Service.

## How do I fix CVE-2017-9735?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.22.v20170606, 9.3.20.v20170531 or 9.4.6.v20170531.

## Is CVE-2017-9735 being exploited?

There is no known exploitation of CVE-2017-9735 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9735 and fix it if it is affected.

What it is: CVE-2017-9735 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9735 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.22.v20170606
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.22.v20170606
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.20.v20170531
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.20.v20170531
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.6.v20170531
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.6.v20170531

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9735/ (Markdown: https://insights.sbomify.com/CVE-2017-9735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9735
- OSV: https://osv.dev/vulnerability/CVE-2017-9735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9735/
Summaries are generated and may contain mistakes; the official description above is the record.
