{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9765 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-9765 is a high-severity vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-9765 and fix it if it is affected.\n\nWhat it is: CVE-2017-9765 is a high-severity vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-9765 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9765/ (Markdown: https://insights.sbomify.com/CVE-2017-9765/index.md)","id":"CVE-2017-9765","markdown":"https://insights.sbomify.com/CVE-2017-9765/index.md","name":"CVE-2017-9765","record":{"aliases":["DEBIAN-CVE-2017-9765","DLA-1036-1","GHSA-h3gg-c3fx-2m67","MGASA-2017-0221","UBUNTU-CVE-2017-9765","openSUSE-SU-2024:10825-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"gSOAP library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service via a large XML document due to an integer overflow in the gSOAP library.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gsoap","vendor":"genivia"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2017-9765","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2017"},"n_packages":1,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-9766"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.8.117-1.2"],"introduced":["0"],"last_affected":[],"package":"gsoap","purl":"pkg:rpm/opensuse/gsoap\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10825-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-9764"},"products":["n/a"],"published":"2017-07-20","related":[{"cvss_score":9.8,"headline":"Integer overflow in Genivia","id":"CVE-2021-21783","kev_date_added":null,"published":"2021-03-25"},{"cvss_score":8.7,"headline":"Genivia gSOAP 2.8 - 'gSOAP' Path Traversal","id":"CVE-2019-25355","kev_date_added":null,"published":"2026-02-18"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2019-6973","kev_date_added":null,"published":"2019-03-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service via a large XML document due to an integer overflow in the gSOAP library.","url":"https://insights.sbomify.com/CVE-2017-9765/"}