# CVE-2017-9785: Deserialization of Untrusted Data in NancyFX Nancy

> Remote code execution is possible via deserialization of JSON data in a CSRF cookie within the NancyFX web framework.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mx3q-j2g2-5qxq

## What is CVE-2017-9785?

CVE-2017-9785 is a critical unsafe deserialization vulnerability in NancyFX Framework Up to 2.0.0, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Csrf.cs in NancyFX Nancy before 1.4.4 and 2.x before 2.0-dangermouse has Remote Code Execution via Deserialization of JSON data in a CSRF Cookie.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-9785?

4 open source packages ship an affected version, including Nancy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Nancy` | NuGet | All versions | 1.4.4 |
| `Nancy` | NuGet | All versions | 1.4.4 |
| `Nancy` | NuGet | From 2.0.0-alpha | 2.0.0 |
| `Nancy` | NuGet | From 2.0.0-alpha | 2.0.0 |

Products: Nancyfx Nancy.

## How do I fix CVE-2017-9785?

Upgrade Nancy to a fixed version for your release line: 1.4.4 or 2.0.0.

## Is CVE-2017-9785 being exploited?

There is no known exploitation of CVE-2017-9785 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9785 and fix it if it is affected.

What it is: CVE-2017-9785 is a critical unsafe deserialization vulnerability in NancyFX Framework Up to 2.0.0, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9785 in the wild and no public exploit code.

Affected packages and fixed versions:
- Nancy (NuGet): affected all versions; fixed in 1.4.4
- Nancy (NuGet): affected all versions; fixed in 1.4.4
- Nancy (NuGet): affected from 2.0.0-alpha; fixed in 2.0.0
- Nancy (NuGet): affected from 2.0.0-alpha; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9785/ (Markdown: https://insights.sbomify.com/CVE-2017-9785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9785
- OSV: https://osv.dev/vulnerability/CVE-2017-9785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9785/
Summaries are generated and may contain mistakes; the official description above is the record.
