CVE-2017-9790 Use after free in Apache Mesos
A malicious actor can crash Apache Mesos masters by sending an HTTP request with an empty path, causing a denial of service for the cluster.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-9790?
CVE-2017-9790 is a high-severity denial of service vulnerability in Apache Mesos, published on 28 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Weakness: CWE-416
Which versions are affected by CVE-2017-9790?
6 open source packages ship an affected version, including org.apache.mesos:mesos. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.mesos:mesos Maven | All versions | 1.1.3 |
org.apache.mesos:mesos Maven | All versions | 1.1.3 |
org.apache.mesos:mesos Maven | From 1.2.0 | 1.2.2 |
org.apache.mesos:mesos Maven | From 1.2.0 | 1.2.2 |
org.apache.mesos:mesos Maven | From 1.3.0 | 1.3.1 |
org.apache.mesos:mesos Maven | From 1.3.0 | 1.3.1 |
Products include Apache Mesos.
How do I fix CVE-2017-9790?
Upgrade org.apache.mesos:mesos to a fixed version for your release line: 1.1.3, 1.2.2 or 1.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-9790 being exploited?
There is no known exploitation of CVE-2017-9790 in the wild and no public exploit code.
Other vulnerabilities in Apache Mesos
Sources
Also known as GHSA-vpcv-78cp-whr3.