# CVE-2017-9790: Use after free in Apache Mesos

> A malicious actor can crash Apache Mesos masters by sending an HTTP request with an empty path, causing a denial of service for the cluster.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vpcv-78cp-whr3

## What is CVE-2017-9790?

CVE-2017-9790 is a high-severity denial of service vulnerability in Apache Mesos, published on 28 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When handling a libprocess message wrapped in an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev crashes if the request path is empty, because the parser assumes the request path always starts with '/'. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2017-9790?

6 open source packages ship an affected version, including org.apache.mesos:mesos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.mesos:mesos` | Maven | All versions | 1.1.3 |
| `org.apache.mesos:mesos` | Maven | All versions | 1.1.3 |
| `org.apache.mesos:mesos` | Maven | From 1.2.0 | 1.2.2 |
| `org.apache.mesos:mesos` | Maven | From 1.2.0 | 1.2.2 |
| `org.apache.mesos:mesos` | Maven | From 1.3.0 | 1.3.1 |
| `org.apache.mesos:mesos` | Maven | From 1.3.0 | 1.3.1 |

Products: Apache Mesos.

## How do I fix CVE-2017-9790?

Upgrade org.apache.mesos:mesos to a fixed version for your release line: 1.1.3, 1.2.2 or 1.3.1.

## Is CVE-2017-9790 being exploited?

There is no known exploitation of CVE-2017-9790 in the wild and no public exploit code.

## Other vulnerabilities in Apache Mesos

- [CVE-2019-5736](https://insights.sbomify.com/CVE-2019-5736/): Privilege escalation in n/a (high 8.6)
- [CVE-2019-0204](https://insights.sbomify.com/CVE-2019-0204/): Docker image code execution with Apache Mesos (high 7.8)
- [CVE-2018-11793](https://insights.sbomify.com/CVE-2018-11793/): Stack Overflow in Apache Mesos (high 7.5)
- [CVE-2018-1330](https://insights.sbomify.com/CVE-2018-1330/): Crash when decoding malformed HTTP requests or malformed JSON payload (high 7.5)
- [CVE-2017-7687](https://insights.sbomify.com/CVE-2017-7687/): Denial of service in Apache Mesos (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9790 and fix it if it is affected.

What it is: CVE-2017-9790 is a high-severity denial of service vulnerability in Apache Mesos, published on 28 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9790 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.mesos:mesos (Maven): affected all versions; fixed in 1.1.3
- org.apache.mesos:mesos (Maven): affected all versions; fixed in 1.1.3
- org.apache.mesos:mesos (Maven): affected from 1.2.0; fixed in 1.2.2
- org.apache.mesos:mesos (Maven): affected from 1.2.0; fixed in 1.2.2
- org.apache.mesos:mesos (Maven): affected from 1.3.0; fixed in 1.3.1
- org.apache.mesos:mesos (Maven): affected from 1.3.0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9790/ (Markdown: https://insights.sbomify.com/CVE-2017-9790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9790
- OSV: https://osv.dev/vulnerability/CVE-2017-9790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9790/
Summaries are generated and may contain mistakes; the official description above is the record.
