CVE-2017-9793 The REST Plugin in Apache Struts is using an outdated XStream library
An attacker can cause a denial of service in Apache Struts REST Plugin by sending malicious XML payloads due to an outdated XStream library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-9793?
CVE-2017-9793 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
Weakness: CWE-20
Which versions are affected by CVE-2017-9793?
4 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-rest-plugin Maven | All versions | 2.3.34 |
org.apache.struts:struts2-rest-plugin Maven | All versions | 2.3.34 |
org.apache.struts:struts2-rest-plugin Maven | From 2.5.0 | 2.5.13 |
org.apache.struts:struts2-rest-plugin Maven | From 2.5.0 | 2.5.13 |
Products include Apache Struts.
How do I fix CVE-2017-9793?
Upgrade org.apache.struts:struts2-rest-plugin to a fixed version for your release line: 2.3.34 or 2.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-9793 being exploited?
There is no known exploitation of CVE-2017-9793 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-vwxj-6m5m-rrvh.