{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9793 in the wild and no public exploit code.","fix":"Upgrade org.apache.struts:struts2-rest-plugin to a fixed version for your release line: 2.3.34 or 2.5.13.","what":"CVE-2017-9793 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-9793 and fix it if it is affected.\n\nWhat it is: CVE-2017-9793 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-9793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.struts:struts2-rest-plugin (Maven): affected all versions; fixed in 2.3.34\n- org.apache.struts:struts2-rest-plugin (Maven): affected all versions; fixed in 2.3.34\n- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.13\n- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9793/ (Markdown: https://insights.sbomify.com/CVE-2017-9793/index.md)","id":"CVE-2017-9793","markdown":"https://insights.sbomify.com/CVE-2017-9793/index.md","name":"CVE-2017-9793","record":{"aliases":["GHSA-vwxj-6m5m-rrvh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Struts REST Plugin","requires_auth":"none","summary":"An attacker can cause a denial of service in Apache Struts REST Plugin by sending malicious XML payloads due to an outdated XStream library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The REST Plugin in Apache Struts is using an outdated XStream library","id":"CVE-2017-9793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"denial_of_service","year":"2017"},"n_packages":4,"n_references":7,"next":{"headline":"Apache Geode gfsh query vulnerability","id":"CVE-2017-9794"},"packages":[{"ecosystem":"Maven","fixed":["2.3.34"],"introduced":["0"],"last_affected":[],"package":"org.apache.struts:struts2-rest-plugin","purl":null,"source":"GHSA-vwxj-6m5m-rrvh"},{"ecosystem":"Maven","fixed":["2.3.34"],"introduced":["0"],"last_affected":[],"package":"org.apache.struts:struts2-rest-plugin","purl":"pkg:maven/org.apache.struts/struts2-rest-plugin","source":"GHSA-vwxj-6m5m-rrvh"},{"ecosystem":"Maven","fixed":["2.5.13"],"introduced":["2.5.0"],"last_affected":[],"package":"org.apache.struts:struts2-rest-plugin","purl":null,"source":"GHSA-vwxj-6m5m-rrvh"},{"ecosystem":"Maven","fixed":["2.5.13"],"introduced":["2.5.0"],"last_affected":[],"package":"org.apache.struts:struts2-rest-plugin","purl":"pkg:maven/org.apache.struts/struts2-rest-plugin","source":"GHSA-vwxj-6m5m-rrvh"}],"prev":{"headline":"Privilege escalation in Apache Impala","id":"CVE-2017-9792"},"products":["Apache Struts"],"published":"2017-09-20","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a denial of service in Apache Struts REST Plugin by sending malicious XML payloads due to an outdated XStream library.","url":"https://insights.sbomify.com/CVE-2017-9793/"}