# CVE-2017-9799: Apache Storm it is possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user

> A topology owner can trick the supervisor into launching a worker as a different user, potentially compromising that user's secure credentials.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-x825-rjww-2245, SUSE-SU-2017:3000-1

## What is CVE-2017-9799?

CVE-2017-9799 is a high-severity vulnerability in Apache Storm, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.

## Which versions are affected by CVE-2017-9799?

4 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-core` | Maven | From 1.0.0 | 1.0.4 |
| `org.apache.storm:storm-core` | Maven | From 1.0.0 | 1.0.4 |
| `org.apache.storm:storm-core` | Maven | From 1.1.0 | 1.1.1 |
| `org.apache.storm:storm-core` | Maven | From 1.1.0 | 1.1.1 |
| `storm` | SUSE:OpenStack Cloud 7 | All versions | 1.0.5-5.3 |

Products: Apache Storm.

## How do I fix CVE-2017-9799?

Upgrade org.apache.storm:storm-core to a fixed version for your release line: 1.0.4 or 1.1.1.

## Is CVE-2017-9799 being exploited?

There is no known exploitation of CVE-2017-9799 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9799 and fix it if it is affected.

What it is: CVE-2017-9799 is a high-severity vulnerability in Apache Storm, published on 9 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-9799 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-core (Maven): affected from 1.0.0; fixed in 1.0.4
- org.apache.storm:storm-core (Maven): affected from 1.0.0; fixed in 1.0.4
- org.apache.storm:storm-core (Maven): affected from 1.1.0; fixed in 1.1.1
- org.apache.storm:storm-core (Maven): affected from 1.1.0; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9799/ (Markdown: https://insights.sbomify.com/CVE-2017-9799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9799
- OSV: https://osv.dev/vulnerability/CVE-2017-9799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9799/
Summaries are generated and may contain mistakes; the official description above is the record.
