{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-email. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9801 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-email to 1.5 or later.","what":"CVE-2017-9801 is a high-severity vulnerability in Apache Commons Email, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-9801 and fix it if it is affected.\n\nWhat it is: CVE-2017-9801 is a high-severity vulnerability in Apache Commons Email, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-9801 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-email (Maven): affected from 1.0; fixed in 1.5\n- org.apache.commons:commons-email (Maven): affected from 1.0; fixed in 1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9801/ (Markdown: https://insights.sbomify.com/CVE-2017-9801/index.md)","id":"CVE-2017-9801","markdown":"https://insights.sbomify.com/CVE-2017-9801/index.md","name":"CVE-2017-9801","record":{"aliases":["GHSA-p7vm-phxx-g722","MGASA-2017-0322","openSUSE-SU-2024:10619-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Java email library","requires_auth":"none","summary":"Attackers can inject arbitrary SMTP headers via line breaks in email subjects, potentially altering email metadata or behavior.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_email","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"When a call-site passes a subject for an email that contains line-breaks in Apache Commons Email 1.0 through 1.4, the caller can add arbitrary SMTP headers.","ecosystems":["Maven","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Apache Commons Email","id":"CVE-2017-9801","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"Improper Neutralization of Input During Web Page Generation Apache Sling Servlets Post","id":"CVE-2017-9802"},"packages":[{"ecosystem":"Maven","fixed":["1.5"],"introduced":["1.0"],"last_affected":[],"package":"org.apache.commons:commons-email","purl":null,"source":"GHSA-p7vm-phxx-g722"},{"ecosystem":"Maven","fixed":["1.5"],"introduced":["1.0"],"last_affected":[],"package":"org.apache.commons:commons-email","purl":"pkg:maven/org.apache.commons/commons-email","source":"GHSA-p7vm-phxx-g722"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.5-3.10"],"introduced":["0"],"last_affected":[],"package":"apache-commons-email","purl":"pkg:rpm/opensuse/apache-commons-email\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10619-1"}],"prev":{"headline":"A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha","id":"CVE-2017-9800"},"products":["Apache Commons Email"],"published":"2017-08-07","related":[{"cvss_score":7.5,"headline":"Improper Input Validation Apache Commons Email","id":"CVE-2018-1294","kev_date_added":null,"published":"2018-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject arbitrary SMTP headers via line breaks in email subjects, potentially altering email metadata or behavior.","url":"https://insights.sbomify.com/CVE-2017-9801/"}