# CVE-2017-9801: Improper Input Validation in Apache Commons Email

> Attackers can inject arbitrary SMTP headers via line breaks in email subjects, potentially altering email metadata or behavior.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p7vm-phxx-g722, MGASA-2017-0322, openSUSE-SU-2024:10619-1

## What is CVE-2017-9801?

CVE-2017-9801 is a high-severity vulnerability in Apache Commons Email, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When a call-site passes a subject for an email that contains line-breaks in Apache Commons Email 1.0 through 1.4, the caller can add arbitrary SMTP headers.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-9801?

2 open source packages ship an affected version, including org.apache.commons:commons-email. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-email` | Maven | From 1.0 | 1.5 |
| `org.apache.commons:commons-email` | Maven | From 1.0 | 1.5 |
| `apache-commons-email` | openSUSE:Tumbleweed | All versions | 1.5-3.10 |

Products: Apache Commons Email.

## How do I fix CVE-2017-9801?

Upgrade org.apache.commons:commons-email to 1.5 or later.

## Is CVE-2017-9801 being exploited?

There is no known exploitation of CVE-2017-9801 in the wild and no public exploit code.

## Other vulnerabilities in Apache Commons Email

- [CVE-2018-1294](https://insights.sbomify.com/CVE-2018-1294/): Improper Input Validation Apache Commons Email (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9801 and fix it if it is affected.

What it is: CVE-2017-9801 is a high-severity vulnerability in Apache Commons Email, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9801 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-email (Maven): affected from 1.0; fixed in 1.5
- org.apache.commons:commons-email (Maven): affected from 1.0; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9801/ (Markdown: https://insights.sbomify.com/CVE-2017-9801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9801
- OSV: https://osv.dev/vulnerability/CVE-2017-9801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9801/
Summaries are generated and may contain mistakes; the official description above is the record.
