# CVE-2017-9802: Improper Neutralization of Input During Web Page Generation Apache Sling Servlets Post

> Cross-site scripting vulnerability in Apache Sling Servlets Post allows attackers to execute arbitrary JavaScript via crafted input strings.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8c82-9rgp-4qvr

## What is CVE-2017-9802?

CVE-2017-9802 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Javascript method Sling.evalString() in Apache Sling Servlets Post before 2.3.22 uses the javascript 'eval' function to parse input strings, which allows for XSS attacks by passing specially crafted input strings.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-9802?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.servlets.post. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.servlets.post` | Maven | All versions | 2.3.22 |
| `org.apache.sling:org.apache.sling.servlets.post` | Maven | All versions | 2.3.22 |

Products: Apache Sling Servlets Post.

## How do I fix CVE-2017-9802?

Upgrade org.apache.sling:org.apache.sling.servlets.post to 2.3.22 or later.

## Is CVE-2017-9802 being exploited?

There is no known exploitation of CVE-2017-9802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9802 and fix it if it is affected.

What it is: CVE-2017-9802 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-9802 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.servlets.post (Maven): affected all versions; fixed in 2.3.22
- org.apache.sling:org.apache.sling.servlets.post (Maven): affected all versions; fixed in 2.3.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9802/ (Markdown: https://insights.sbomify.com/CVE-2017-9802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9802
- OSV: https://osv.dev/vulnerability/CVE-2017-9802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9802/
Summaries are generated and may contain mistakes; the official description above is the record.
