CVE-2017-9804 Apache Struts allows entering a custom URL in a form field if built-in URLValidator is used
Attackers can cause server overload and denial of service by submitting specially crafted URLs to applications using the built-in URLValidator in Apache Struts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-9804?
CVE-2017-9804 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.
Weakness: CWE-20
Which versions are affected by CVE-2017-9804?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.3.7 | 2.3.34 |
org.apache.struts:struts2-core Maven | From 2.3.7 | 2.3.34 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.13 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.13 |
Products include Apache Struts.
How do I fix CVE-2017-9804?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.34 or 2.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-9804 being exploited?
There is no known exploitation of CVE-2017-9804 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-x5x7-3v85-wpc4.