# CVE-2017-9804: Apache Struts allows entering a custom URL in a form field if built-in URLValidator is used

> Attackers can cause server overload and denial of service by submitting specially crafted URLs to applications using the built-in URLValidator in Apache Struts.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-x5x7-3v85-wpc4

## What is CVE-2017-9804?

CVE-2017-9804 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL.  NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-9804?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.3.7 | 2.3.34 |
| `org.apache.struts:struts2-core` | Maven | From 2.3.7 | 2.3.34 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.13 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.13 |

Products: Apache Struts.

## How do I fix CVE-2017-9804?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.34 or 2.5.13.

## Is CVE-2017-9804 being exploited?

There is no known exploitation of CVE-2017-9804 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9804 and fix it if it is affected.

What it is: CVE-2017-9804 is a high-severity denial of service vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9804 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.3.7; fixed in 2.3.34
- org.apache.struts:struts2-core (Maven): affected from 2.3.7; fixed in 2.3.34
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.13
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9804/ (Markdown: https://insights.sbomify.com/CVE-2017-9804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9804
- OSV: https://osv.dev/vulnerability/CVE-2017-9804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9804/
Summaries are generated and may contain mistakes; the official description above is the record.
