# CVE-2017-9805: Apache Struts Deserialization of Untrusted Data

> Attackers can execute arbitrary code by sending malicious XML payloads to the REST plugin due to unsafe deserialization in Apache Struts.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2017
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-gg9m-fj3v-r58c

## What is CVE-2017-9805?

CVE-2017-9805 is a high-severity unsafe deserialization vulnerability in Apache Struts, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStream for deserialization without any type filtering, which can lead to Remote Code Execution when deserializing XML payloads.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-9805?

4 open source packages ship an affected version, including org.apache.struts:struts2-rest-plugin. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.1.1 | 2.3.34 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.1.1 | 2.3.34 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.5.0 | 2.5.13 |
| `org.apache.struts:struts2-rest-plugin` | Maven | From 2.5.0 | 2.5.13 |

Products: Apache Struts, Cisco Digital Media Manager, Cisco Hosted Collaboration Solution, Cisco Media Experience Engine, Cisco Network Performance Analysis, Cisco Video Distribution Suite for Internet Streaming, Netapp Oncommand Balance.

## How do I fix CVE-2017-9805?

Upgrade org.apache.struts:struts2-rest-plugin to a fixed version for your release line: 2.3.34 or 2.5.13. US federal agencies must fix it by 3 May 2022.

## Is CVE-2017-9805 being exploited?

Yes. Attackers have exploited CVE-2017-9805 in the wild since at least 3 Nov 2021.

Public exploit code:

- An exploit for Apache Struts CVE-2017-9805 (github_poc): https://github.com/mazen160/struts-pwn_CVE-2017-9805
- CVE 2017-9805 (github_poc): https://github.com/luc10/struts-rce-cve-2017-9805
- Better Exploit Code For CVE 2017 9805 apache struts (github_poc): https://github.com/chrisjd20/cve-2017-9805.py
- Exploit script for Apache Struts2 REST Plugin XStream RCE (‎CVE-2017-9805) (github_poc): https://github.com/0x00-0x00/-CVE-2017-9805
- An exploit for Apache Struts CVE-2017-9805 (github_poc): https://github.com/Lone-Ranger/apache-struts-pwn_CVE-2017-9805
- cve -2017-9805 (github_poc): https://github.com/hahwul/struts2-rce-cve-2017-9805-ruby

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9805 and fix it if it is affected.

What it is: CVE-2017-9805 is a high-severity unsafe deserialization vulnerability in Apache Struts, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2017-9805 in the wild since at least 3 Nov 2021.

Affected packages and fixed versions:
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.1.1; fixed in 2.3.34
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.1.1; fixed in 2.3.34
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.13
- org.apache.struts:struts2-rest-plugin (Maven): affected from 2.5.0; fixed in 2.5.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9805/ (Markdown: https://insights.sbomify.com/CVE-2017-9805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9805
- OSV: https://osv.dev/vulnerability/CVE-2017-9805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9805/
Summaries are generated and may contain mistakes; the official description above is the record.
