# CVE-2017-9822: DotNetNuke (DNN) Remote Code Execution

> Attackers can achieve remote code execution on DNN sites by exploiting a deserialization vulnerability in cookies.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV), used in ransomware
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2017
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-x2rg-fmcv-crq5

## What is CVE-2017-9822?

CVE-2017-9822 is a high-severity unsafe deserialization vulnerability in Dnnsoftware Dotnetnuke, published on 20 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DNN (aka DotNetNuke) before 9.1.1 has Remote Code Execution via a cookie, aka "2017-08 (Critical) Possible remote code execution on DNN sites."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-9822?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.1.1 |
| `DotNetNuke.Core` | NuGet | All versions | 9.1.1 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2017-9822?

Upgrade DotNetNuke.Core to 9.1.1 or later. US federal agencies must fix it by 3 May 2022.

## Is CVE-2017-9822 being exploited?

Yes. Attackers have exploited CVE-2017-9822 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Public exploit code:

- [CVE-2017-9822] DotNetNuke Cookie Deserialization Remote Code Execution (RCE) (github_poc): https://github.com/murataydemir/CVE-2017-9822
- DotNetNuke Cookie Deserialization Remote Code Excecution (metasploit)
- DotNetNuke - Cookie Deserialization Remote Code Execution (Metasploit) (exploitdb)
- https://github.com/tranphuc2005/CVE-2017-9822 (github_poc): https://github.com/tranphuc2005/CVE-2017-9822
- https://github.com/Tnot123/cve-2017-9822 (github_poc): https://github.com/Tnot123/cve-2017-9822
- DotNetNuke 5.0.0 - 9.3.0 - Cookie Deserialization Remote Code Execution (nuclei): http/cves/2017/CVE-2017-9822.yaml

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)
- [CVE-2015-2794](https://insights.sbomify.com/CVE-2015-2794/): The installation wizard in DotNetNuke (DNN) allows privilege escalation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9822 and fix it if it is affected.

What it is: CVE-2017-9822 is a high-severity unsafe deserialization vulnerability in Dnnsoftware Dotnetnuke, published on 20 Jul 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2017-9822 in the wild since at least 3 Nov 2021, including in ransomware campaigns.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.1.1
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9822/ (Markdown: https://insights.sbomify.com/CVE-2017-9822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9822
- OSV: https://osv.dev/vulnerability/CVE-2017-9822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9822/
Summaries are generated and may contain mistakes; the official description above is the record.
