{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9838 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 5.0.4 or later.","what":"CVE-2017-9838 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 11 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-9838 and fix it if it is affected.\n\nWhat it is: CVE-2017-9838 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 11 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-9838 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 5.0.4\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 5.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9838/ (Markdown: https://insights.sbomify.com/CVE-2017-9838/index.md)","id":"CVE-2017-9838","markdown":"https://insights.sbomify.com/CVE-2017-9838/index.md","name":"CVE-2017-9838","record":{"aliases":["GHSA-726g-cgcq-4xw8","UBUNTU-CVE-2017-9838"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via multiple parameters in Dolibarr, potentially stealing user sessions or executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Dolibarr ERP/CRM is affected by multiple reflected Cross-Site Scripting (XSS) vulnerabilities in versions before 5.0.4: index.php (leftmenu parameter), core/ajax/box.php (PATH_INFO), product/stats/card.php (type parameter), holiday/list.php (month_create, month_start, and month_end parameters), and don/card.php (societe, lastname, firstname, address, zipcode, town, and email parameters).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dolibarr Cross-Site Scripting (XSS) vulnerability","id":"CVE-2017-9838","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Dolibarr SQL injection via type parameter in product/stats/card.php","id":"CVE-2017-9839"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.4"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-726g-cgcq-4xw8"},{"ecosystem":"Packagist","fixed":["5.0.4"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-726g-cgcq-4xw8"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-9837"},"products":["n/a"],"published":"2018-04-11","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via multiple parameters in Dolibarr, potentially stealing user sessions or executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2017-9838/"}