# CVE-2018-0023: Junos Snapshot Administrator (JSNAPy) world writeable default configuration file permission

> Unprivileged local users can modify world-writable configuration files in JSNAPy, potentially altering intended automation operations.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qc55-vm3j-74gp, PYSEC-2018-84

## What is CVE-2018-0023?

CVE-2018-0023 is a medium-severity vulnerability in Juniper Networks Junos Snapshot Administrator (JSNAPy), published on 11 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

JSNAPy is an open source python version of Junos Snapshot Administrator developed by Juniper available through github. The default configuration and sample files of JSNAPy automation tool versions prior to 1.3.0 are created world writable. This insecure file and directory permission allows unprivileged local users to alter the files under this directory including inserting operations not intended by the package maintainer, system administrator, or other users. This issue only affects users who downloaded and installed JSNAPy from github.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2018-0023?

3 open source packages ship an affected version, including jsnapy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsnapy` | PyPI | All versions | 1.3.0 |
| `jsnapy` | PyPI | All versions | 1.3.0 |
| `jsnapy` | PyPI | All versions | 1.3.0 |

Products: Juniper Jsnapy.

## How do I fix CVE-2018-0023?

Upgrade jsnapy to 1.3.0 or later.

## Is CVE-2018-0023 being exploited?

There is no known exploitation of CVE-2018-0023 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0023 and fix it if it is affected.

What it is: CVE-2018-0023 is a medium-severity vulnerability in Juniper Networks Junos Snapshot Administrator (JSNAPy), published on 11 Apr 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-0023 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsnapy (PyPI): affected all versions; fixed in 1.3.0
- jsnapy (PyPI): affected all versions; fixed in 1.3.0
- jsnapy (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0023/ (Markdown: https://insights.sbomify.com/CVE-2018-0023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0023
- OSV: https://osv.dev/vulnerability/CVE-2018-0023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0023/
Summaries are generated and may contain mistakes; the official description above is the record.
