{"answers":{"affected":"2 open source packages ship an affected version, including xapian-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-0499 in the wild and no public exploit code.","fix":"Upgrade xapian-core to 1.4.6 or later.","what":"CVE-2018-0499 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-0499 and fix it if it is affected.\n\nWhat it is: CVE-2018-0499 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-0499 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- xapian-core (RubyGems): affected all versions; fixed in 1.4.6\n- xapian-core (RubyGems): affected all versions; fixed in 1.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-0499/ (Markdown: https://insights.sbomify.com/CVE-2018-0499/index.md)","id":"CVE-2018-0499","markdown":"https://insights.sbomify.com/CVE-2018-0499/index.md","name":"CVE-2018-0499","record":{"aliases":["ALPINE-CVE-2018-0499","DEBIAN-CVE-2018-0499","GHSA-7qw4-w7hf-22q3","UBUNTU-CVE-2018-0499","USN-3709-1","openSUSE-SU-2024:11516-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Xapian search library","requires_auth":"none","summary":"An attacker can inject malicious scripts via incomplete HTML escaping in Xapian's snippet generation, potentially leading to code execution in the context of the application using the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"xapian-core","vendor":"xapian"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().","ecosystems":["RubyGems","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"xapian-core Cross-site Scripting vulnerability","id":"CVE-2018-0499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"xss","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in curl before 7.61.0","id":"CVE-2018-0500"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.6"],"introduced":["0"],"last_affected":[],"package":"xapian-core","purl":null,"source":"GHSA-7qw4-w7hf-22q3"},{"ecosystem":"RubyGems","fixed":["1.4.6"],"introduced":["0"],"last_affected":[],"package":"xapian-core","purl":"pkg:gem/xapian-core","source":"GHSA-7qw4-w7hf-22q3"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.18-1.6"],"introduced":["0"],"last_affected":[],"package":"xapian","purl":"pkg:rpm/opensuse/xapian\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11516-1"}],"prev":{"headline":"Information disclosure in ARM mbed TLS before 2.12.0, before 2.7.5, and before 2.1.14","id":"CVE-2018-0498"},"products":["Xapian xapian-core before 1.4.6"],"published":"2018-07-02","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via incomplete HTML escaping in Xapian's snippet generation, potentially leading to code execution in the context of the application using the library.","url":"https://insights.sbomify.com/CVE-2018-0499/"}