# CVE-2018-0499: xapian-core Cross-site Scripting vulnerability

> An attacker can inject malicious scripts via incomplete HTML escaping in Xapian's snippet generation, potentially leading to code execution in the context of the application using the library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-0499, DEBIAN-CVE-2018-0499, GHSA-7qw4-w7hf-22q3, UBUNTU-CVE-2018-0499, USN-3709-1, openSUSE-SU-2024:11516-1

## What is CVE-2018-0499?

CVE-2018-0499 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-0499?

2 open source packages ship an affected version, including xapian-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xapian-core` | RubyGems | All versions | 1.4.6 |
| `xapian-core` | RubyGems | All versions | 1.4.6 |
| `xapian` | openSUSE:Tumbleweed | All versions | 1.4.18-1.6 |

Products: Canonical Ubuntu Linux, Xapian Xapian-Core.

## How do I fix CVE-2018-0499?

Upgrade xapian-core to 1.4.6 or later.

## Is CVE-2018-0499 being exploited?

There is no known exploitation of CVE-2018-0499 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0499 and fix it if it is affected.

What it is: CVE-2018-0499 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-0499 in the wild and no public exploit code.

Affected packages and fixed versions:
- xapian-core (RubyGems): affected all versions; fixed in 1.4.6
- xapian-core (RubyGems): affected all versions; fixed in 1.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0499/ (Markdown: https://insights.sbomify.com/CVE-2018-0499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0499
- OSV: https://osv.dev/vulnerability/CVE-2018-0499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0499/
Summaries are generated and may contain mistakes; the official description above is the record.
