{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-0500 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-0500 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 11 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-0500 and fix it if it is affected.\n\nWhat it is: CVE-2018-0500 is a critical memory corruption vulnerability in Canonical Ubuntu Linux, published on 11 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-0500 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-0500/ (Markdown: https://insights.sbomify.com/CVE-2018-0500/index.md)","id":"CVE-2018-0500","markdown":"https://insights.sbomify.com/CVE-2018-0500/index.md","name":"CVE-2018-0500","record":{"aliases":["ALPINE-CVE-2018-0500","CLEANSTART-2026-OO33061","CURL-CVE-2018-0500","DEBIAN-CVE-2018-0500","GHSA-rg4c-f6cj-x9w8","SUSE-SU-2018:2423-1","UBUNTU-CVE-2018-0500","USN-3710-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"curl library","requires_auth":"none","summary":"Heap-based buffer overflow in curl's SMTP handling allows attackers to execute code or cause denial of service when nonstandard buffer settings are used.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"curl","vendor":"haxx"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Curl_smtp_escape_eob in lib/smtp.c in curl 7.54.1 to and including curl 7.60.0 has a heap-based buffer overflow that might be exploitable by an attacker who can control the data that curl transmits over SMTP with certain settings (i.e., use of a nonstandard --limit-rate argument or CURLOPT_BUFFERSIZE value).","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in curl before 7.61.0","id":"CVE-2018-0500","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","haxx:curl"],"type":"memory_corruption","year":"2018"},"n_packages":1,"n_references":6,"next":{"headline":"Security feature bypass in APT 1.6.x before 1.6.4 and 1.7.x before 1.7.0~alpha3","id":"CVE-2018-0501"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["7.60.0-3.6.4"],"introduced":["0"],"last_affected":[],"package":"curl","purl":"pkg:rpm/suse/curl\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2018:2423-1"}],"prev":{"headline":"xapian-core Cross-site Scripting vulnerability","id":"CVE-2018-0499"},"products":["curl before 7.61.0"],"published":"2018-07-11","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Heap-based buffer overflow in curl's SMTP handling allows attackers to execute code or cause denial of service when nonstandard buffer settings are used.","url":"https://insights.sbomify.com/CVE-2018-0500/"}