{"answers":{"affected":"8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-0503 in the wild and no public exploit code.","fix":"Upgrade mediawiki/core to a fixed version for your release line: 1.27.5, 1.29.3, 1.30.1 or 1.31.1.","what":"CVE-2018-0503 is a medium-severity vulnerability in Debian Debian Linux, published on 4 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-0503 and fix it if it is affected.\n\nWhat it is: CVE-2018-0503 is a medium-severity vulnerability in Debian Debian Linux, published on 4 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-0503 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.5\n- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.5\n- mediawiki/core (Packagist): affected from 1.29.0; fixed in 1.29.3\n- mediawiki/core (Packagist): affected from 1.29.0; fixed in 1.29.3\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.1\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.1\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.1\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-0503/ (Markdown: https://insights.sbomify.com/CVE-2018-0503/index.md)","id":"CVE-2018-0503","markdown":"https://insights.sbomify.com/CVE-2018-0503/index.md","name":"CVE-2018-0503","record":{"aliases":["DEBIAN-CVE-2018-0503","GHSA-mhfv-9h99-jwg7","UBUNTU-CVE-2018-0503"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"low_privilege","summary":"MediaWiki rate limiting configuration flaw allows users to bypass restrictions intended for new accounts, potentially enabling abuse.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"$wgRateLimits entry for 'user' overrides 'newbie'","id":"CVE-2018-0503","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","mediawiki:mediawiki"],"type":"security_feature_bypass","year":"2018"},"n_packages":8,"n_references":7,"next":{"headline":"Information disclosure in Special:Redirect/logid","id":"CVE-2018-0504"},"packages":[{"ecosystem":"Packagist","fixed":["1.27.5"],"introduced":["1.27.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.27.5"],"introduced":["1.27.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.29.3"],"introduced":["1.29.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.29.3"],"introduced":["1.29.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.30.1"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.30.1"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.31.1"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-mhfv-9h99-jwg7"},{"ecosystem":"Packagist","fixed":["1.31.1"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-mhfv-9h99-jwg7"}],"prev":{"headline":"An issue was discovered in zsh before 5.6.","id":"CVE-2018-0502"},"products":["mediawiki"],"published":"2018-10-04","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["mediawiki"]},"summary":"MediaWiki rate limiting configuration flaw allows users to bypass restrictions intended for new accounts, potentially enabling abuse.","url":"https://insights.sbomify.com/CVE-2018-0503/"}