CVE-2018-0504 Information disclosure in Special:Redirect/logid
An attacker can access sensitive log information via the Special:Redirect/logid page in MediaWiki.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-0504?
CVE-2018-0504 is a medium-severity vulnerability in Debian Debian Linux, published on 4 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains an information disclosure flaw in the Special:Redirect/logid
Weakness: CWE-532
Which versions are affected by CVE-2018-0504?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.5 |
mediawiki/core Packagist | From 1.27.0 | 1.27.5 |
mediawiki/core Packagist | From 1.29.0 | 1.29.3 |
mediawiki/core Packagist | From 1.29.0 | 1.29.3 |
mediawiki/core Packagist | From 1.30.0 | 1.30.1 |
mediawiki/core Packagist | From 1.30.0 | 1.30.1 |
2 more packages
mediawiki/core Packagist | From 1.31.0 | 1.31.1 |
mediawiki/core Packagist | From 1.31.0 | 1.31.1 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2018-0504?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.5, 1.29.3, 1.30.1 or 1.31.1.
Is CVE-2018-0504 being exploited?
There is no known exploitation of CVE-2018-0504 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-0504, GHSA-hr8v-f4g2-p66f, UBUNTU-CVE-2018-0504.