# CVE-2018-0505: BotPasswords can bypass CentralAuth's account lock

> Attackers can bypass CentralAuth account locks using BotPasswords, allowing unauthorized access to locked MediaWiki accounts.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-0505, GHSA-5c6w-f4w2-2grp, UBUNTU-CVE-2018-0505

## What is CVE-2018-0505?

CVE-2018-0505 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 4 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where BotPasswords can bypass CentralAuth's account lock

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-0505?

8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | From 1.27.0 | 1.27.5 |
| `mediawiki/core` | Packagist | From 1.27.0 | 1.27.5 |
| `mediawiki/core` | Packagist | From 1.29.0 | 1.29.3 |
| `mediawiki/core` | Packagist | From 1.29.0 | 1.29.3 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.1 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.1 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.1 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.1 |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2018-0505?

Upgrade mediawiki/core to a fixed version for your release line: 1.27.5, 1.29.3, 1.30.1 or 1.31.1.

## Is CVE-2018-0505 being exploited?

There is no known exploitation of CVE-2018-0505 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0505 and fix it if it is affected.

What it is: CVE-2018-0505 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 4 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-0505 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.5
- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.5
- mediawiki/core (Packagist): affected from 1.29.0; fixed in 1.29.3
- mediawiki/core (Packagist): affected from 1.29.0; fixed in 1.29.3
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.1
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.1
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.1
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0505/ (Markdown: https://insights.sbomify.com/CVE-2018-0505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0505
- OSV: https://osv.dev/vulnerability/CVE-2018-0505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0505/
Summaries are generated and may contain mistakes; the official description above is the record.
