# CVE-2018-0524: Code injection in Jubatus

> Remote attackers can execute arbitrary code on systems using the Jubatus machine learning library.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hr8g-qqq7-pqgj, PYSEC-2018-114

## What is CVE-2018-0524?

CVE-2018-0524 is a high-severity code injection vulnerability in Jubatus, published on 9 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jubatus 1.0.2 and earlier allows remote code execution via unspecified vectors.

## Which versions are affected by CVE-2018-0524?

1 open source package ship an affected version, including jubatus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jubatus` | PyPI | All versions | 1.1.0 |

Products: Jubat Jubatus.

## How do I fix CVE-2018-0524?

Upgrade jubatus to 1.1.0 or later.

## Is CVE-2018-0524 being exploited?

There is no known exploitation of CVE-2018-0524 in the wild and no public exploit code.

## Other vulnerabilities in Jubatus

- [CVE-2018-0525](https://insights.sbomify.com/CVE-2018-0525/): Path traversal in Jubatus (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0524 and fix it if it is affected.

What it is: CVE-2018-0524 is a high-severity code injection vulnerability in Jubatus, published on 9 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-0524 in the wild and no public exploit code.

Affected packages and fixed versions:
- jubatus (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0524/ (Markdown: https://insights.sbomify.com/CVE-2018-0524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0524
- OSV: https://osv.dev/vulnerability/CVE-2018-0524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0524/
Summaries are generated and may contain mistakes; the official description above is the record.
