# CVE-2018-0525: Path traversal in Jubatus

> Remote attackers can read arbitrary files from the server due to a directory traversal flaw in the Jubatus library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v657-49gp-q7jv, PYSEC-2018-115

## What is CVE-2018-0525?

CVE-2018-0525 is a medium-severity path traversal vulnerability in Jubatus, published on 9 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Jubatus 1.0.2 and earlier allows remote attackers to read arbitrary files via unspecified vectors.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-0525?

1 open source package ship an affected version, including jubatus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jubatus` | PyPI | All versions | 1.1.0 |

Products: Jubat Jubatus.

## How do I fix CVE-2018-0525?

Upgrade jubatus to 1.1.0 or later.

## Is CVE-2018-0525 being exploited?

There is no known exploitation of CVE-2018-0525 in the wild and no public exploit code.

## Other vulnerabilities in Jubatus

- [CVE-2018-0524](https://insights.sbomify.com/CVE-2018-0524/): Code injection in Jubatus (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0525 and fix it if it is affected.

What it is: CVE-2018-0525 is a medium-severity path traversal vulnerability in Jubatus, published on 9 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-0525 in the wild and no public exploit code.

Affected packages and fixed versions:
- jubatus (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0525/ (Markdown: https://insights.sbomify.com/CVE-2018-0525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0525
- OSV: https://osv.dev/vulnerability/CVE-2018-0525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0525/
Summaries are generated and may contain mistakes; the official description above is the record.
