{"answers":{"affected":"4 open source packages ship an affected version, including baserproject/basercms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-0570 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-0570 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-0570 is a medium-severity cross-site scripting vulnerability in Basercms Basercms, published on 26 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-0570 and fix it if it is affected.\n\nWhat it is: CVE-2018-0570 is a medium-severity cross-site scripting vulnerability in Basercms Basercms, published on 26 Jun 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-0570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- baserproject/basercms (Packagist): affected all versions up to 3.0.15; no fix listed\n- baserproject/basercms (Packagist): affected all versions up to 3.0.15; no fix listed\n- baserproject/basercms (Packagist): affected from 4.0.0 up to 4.1.0.1; no fix listed\n- baserproject/basercms (Packagist): affected from 4.0.0 up to 4.1.0.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-0570/ (Markdown: https://insights.sbomify.com/CVE-2018-0570/index.md)","id":"CVE-2018-0570","markdown":"https://insights.sbomify.com/CVE-2018-0570/index.md","name":"CVE-2018-0570","record":{"aliases":["GHSA-994g-74gq-5qpr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"baserCMS","requires_auth":"low_privilege","summary":"Remote authenticated attackers can inject arbitrary web script or HTML into baserCMS, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"basercms","vendor":"basercms"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting vulnerability in baserCMS (baserCMS 4.1.0.1 and earlier versions, baserCMS 3.0.15 and earlier versions) allows remote authenticated attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"XSS in baserCMS","id":"CVE-2018-0570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"basercms:basercms","products":["basercms:basercms"],"type":"xss","year":"2018"},"n_packages":4,"n_references":2,"next":{"headline":"baserCMS arbitrary file upload vulnerability","id":"CVE-2018-0571"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.0.15"],"package":"baserproject/basercms","purl":null,"source":"GHSA-994g-74gq-5qpr"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.0.15"],"package":"baserproject/basercms","purl":"pkg:composer/baserproject/basercms","source":"GHSA-994g-74gq-5qpr"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0"],"last_affected":["4.1.0.1"],"package":"baserproject/basercms","purl":null,"source":"GHSA-994g-74gq-5qpr"},{"ecosystem":"Packagist","fixed":[],"introduced":["4.0.0"],"last_affected":["4.1.0.1"],"package":"baserproject/basercms","purl":"pkg:composer/baserproject/basercms","source":"GHSA-994g-74gq-5qpr"}],"prev":{"headline":"OS Command Injection in baserCMS","id":"CVE-2018-0569"},"products":["baserCMS"],"published":"2018-06-26","related":[{"cvss_score":9.8,"headline":"baserCMS File Uploader Remote Code Execution (RCE) vulnerability","id":"CVE-2023-25654","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS allows any file to be uploaded","id":"CVE-2023-25655","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS SQL Injection vulnerability","id":"CVE-2017-10842","kev_date_added":null,"published":"2017-08-28"},{"cvss_score":9.2,"headline":"baserCMS: OS command injection vulnerability in installer","id":"CVE-2026-30880","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection Leading to Remote Code Execution (RCE)","id":"CVE-2026-21861","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection in the baserCMS Update Functionality","id":"CVE-2026-30877","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"OS Command Injection Vulnerability and Potential Zip Slip Vulnerability","id":"CVE-2021-41243","kev_date_added":null,"published":"2021-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["baserCMS Users Community"]},"summary":"Remote authenticated attackers can inject arbitrary web script or HTML into baserCMS, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2018-0570/"}