# CVE-2018-0764: Denial of service vulnerability exists when .NET and .NET Core improperly process XML documents

> Attackers can cause a denial of service in Microsoft .NET Framework and Core by exploiting improper XML document processing.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rr3c-f55v-qhv5, RHSA-2018:0379

## What is CVE-2018-0764?

CVE-2018-0764 is a high-severity denial of service vulnerability in Microsoft .Net Framework, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Microsoft .NET Framework 1.1, 2.0, 3.0, 3.5, 3.5.1, 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2 and 5.7 and .NET Core 1.0. 1.1 and 2.0 allow a denial of service vulnerability due to the way XML documents are processed, aka ".NET and .NET Core Denial Of Service Vulnerability". This CVE is unique from CVE-2018-0765.

## Which versions are affected by CVE-2018-0764?

2 open source packages ship an affected version, including System.Security.Cryptography.Xml. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `System.Security.Cryptography.Xml` | NuGet | All versions | 4.4.2 |
| `System.Security.Cryptography.Xml` | NuGet | All versions | 4.4.2 |
| `rh-dotnetcore10-dotnetcore` | Red Hat:rhel_dotnet:1.0::el7 | All versions | 0:1.0.9-1.el7 |
| `rh-dotnetcore10-dotnetcore-debuginfo` | Red Hat:rhel_dotnet:1.0::el7 | All versions | 0:1.0.9-1.el7 |
| `rh-dotnetcore11-dotnetcore` | Red Hat:rhel_dotnet:1.1::el7 | All versions | 0:1.1.6-1.el7 |
| `rh-dotnetcore11-dotnetcore-debuginfo` | Red Hat:rhel_dotnet:1.1::el7 | All versions | 0:1.1.6-1.el7 |
| `rh-dotnet20-dotnet` | Red Hat:rhel_dotnet:2.0::el7 | All versions | 0:2.0.5-1.el7 |
| `rh-dotnet20-dotnet-debuginfo` | Red Hat:rhel_dotnet:2.0::el7 | All versions | 0:2.0.5-1.el7 |
| `rh-dotnet20-dotnet-host` | Red Hat:rhel_dotnet:2.0::el7 | All versions | 0:2.0.5-1.el7 |
| `rh-dotnet20-dotnet-runtime-2.0` | Red Hat:rhel_dotnet:2.0::el7 | All versions | 0:2.0.5-1.el7 |
| `rh-dotnet20-dotnet-sdk-2.1` | Red Hat:rhel_dotnet:2.0::el7 | All versions | 0:2.1.4-1.el7 |

Products: Microsoft .Net Core, Microsoft .Net Framework, Microsoft Powershell Core.

## How do I fix CVE-2018-0764?

Upgrade System.Security.Cryptography.Xml to 4.4.2 or later.

## Is CVE-2018-0764 being exploited?

There is no known exploitation of CVE-2018-0764 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft .Net Framework

- [CVE-2020-1147](https://insights.sbomify.com/CVE-2020-1147/): Microsoft .NET Framework, SharePoint, and Visual Studio Remote Code Execution (high 7.8, exploited in the wild)
- [CVE-2020-0605](https://insights.sbomify.com/CVE-2020-0605/): Code injection in .NET Core (high 8.8)
- [CVE-2020-0606](https://insights.sbomify.com/CVE-2020-0606/): Remote code execution in Microsoft.WindowsDesktop.App.Ref (high 8.8)
- [CVE-2019-1301](https://insights.sbomify.com/CVE-2019-1301/): High severity vulnerability that affects System.Management.Automation (high 7.5)
- [CVE-2019-0820](https://insights.sbomify.com/CVE-2019-0820/): Regular Expression Denial of Service in System.Text.RegularExpressions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0764 and fix it if it is affected.

What it is: CVE-2018-0764 is a high-severity denial of service vulnerability in Microsoft .Net Framework, published on 10 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-0764 in the wild and no public exploit code.

Affected packages and fixed versions:
- System.Security.Cryptography.Xml (NuGet): affected all versions; fixed in 4.4.2
- System.Security.Cryptography.Xml (NuGet): affected all versions; fixed in 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0764/ (Markdown: https://insights.sbomify.com/CVE-2018-0764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0764
- OSV: https://osv.dev/vulnerability/CVE-2018-0764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0764/
Summaries are generated and may contain mistakes; the official description above is the record.
