# CVE-2018-0787: ASP.NET Core allow an elevation of privilege

> Attackers can elevate privileges by exploiting how template-based web applications validate requests in ASP.NET Core.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-365p-96qv-xr7g

## What is CVE-2018-0787?

CVE-2018-0787 is a high-severity vulnerability in Microsoft Corporation ASP.NET Core, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2018-0787?

4 open source packages ship an affected version, including Microsoft.AspNetCore.HttpOverrides and Microsoft.AspNetCore.Server.Kestrel.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.AspNetCore.HttpOverrides` | NuGet | From 2.0.0 | 2.0.2 |
| `Microsoft.AspNetCore.HttpOverrides` | NuGet | From 2.0.0 | 2.0.2 |
| `Microsoft.AspNetCore.Server.Kestrel.Core` | NuGet | From 2.0.0 | 2.0.2 |
| `Microsoft.AspNetCore.Server.Kestrel.Core` | NuGet | From 2.0.0 | 2.0.2 |

Products: Microsoft Asp.net Core.

## How do I fix CVE-2018-0787?

Upgrade Microsoft.AspNetCore.HttpOverrides to 2.0.2 or later.

## Is CVE-2018-0787 being exploited?

There is no known exploitation of CVE-2018-0787 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft Corporation ASP.NET Core

- [CVE-2025-55315](https://insights.sbomify.com/CVE-2025-55315/): ASP.NET Security Feature Bypass Vulnerability (critical 9.9)
- [CVE-2026-88092](https://insights.sbomify.com/CVE-2026-88092/): ASP.NET Core Tampering Vulnerability (critical 9.4)
- [CVE-2026-40372](https://insights.sbomify.com/CVE-2026-40372/): ASP.NET Core Elevation of Privilege Vulnerability (critical 9.1)
- [CVE-2021-43877](https://insights.sbomify.com/CVE-2021-43877/): ASP.NET Core and Visual Studio Elevation of Privilege Vulnerability (high 8.8)
- [CVE-2020-0603](https://insights.sbomify.com/CVE-2020-0603/): Remote code execution in ASP.NET Core (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-0787 and fix it if it is affected.

What it is: CVE-2018-0787 is a high-severity vulnerability in Microsoft Corporation ASP.NET Core, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-0787 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.AspNetCore.HttpOverrides (NuGet): affected from 2.0.0; fixed in 2.0.2
- Microsoft.AspNetCore.HttpOverrides (NuGet): affected from 2.0.0; fixed in 2.0.2
- Microsoft.AspNetCore.Server.Kestrel.Core (NuGet): affected from 2.0.0; fixed in 2.0.2
- Microsoft.AspNetCore.Server.Kestrel.Core (NuGet): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-0787/ (Markdown: https://insights.sbomify.com/CVE-2018-0787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-0787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-0787
- OSV: https://osv.dev/vulnerability/CVE-2018-0787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-0787/
Summaries are generated and may contain mistakes; the official description above is the record.
