# CVE-2018-1000006: Remote Code Execution in electron

> Attackers can execute arbitrary commands on Windows systems if users click crafted URLs in Electron apps with custom protocol handlers.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w222-53c6-c86p

## What is CVE-2018-1000006?

CVE-2018-1000006 is a high-severity command injection vulnerability in n/a, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GitHub Electron versions 1.8.2-beta.3 and earlier, 1.7.10 and earlier, 1.6.15 and earlier has a vulnerability in the protocol handler, specifically Electron apps running on Windows 10, 7 or 2008 that register custom protocol handlers can be tricked in arbitrary command execution if the user clicks on a specially crafted URL. This has been fixed in versions 1.8.2-beta.4, 1.7.11, and 1.6.16.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2018-1000006?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 1.6.0 | 1.6.16 |
| `electron` | npm | From 1.6.0 | 1.6.16 |
| `electron` | npm | From 1.7.0 | 1.7.11 |
| `electron` | npm | From 1.7.0 | 1.7.11 |
| `electron` | npm | From 1.8.0 | 1.8.2-beta.4 |
| `electron` | npm | From 1.8.0 | 1.8.2-beta.4 |

Products: Atom Electron.

## How do I fix CVE-2018-1000006?

Upgrade electron to a fixed version for your release line: 1.6.16, 1.7.11 or 1.8.2-beta.4.

## Is CVE-2018-1000006 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000006 exists.

Public exploit code:

- The Demo for CVE-2018-1000006 (github_poc): https://github.com/CHYbeta/CVE-2018-1000006-DEMO
- Exodus Wallet (ElectronJS Framework) - Remote Code Execution (exploitdb)
- Exodus Wallet (ElectronJS Framework) remote Code Execution (metasploit)
- Exodus Wallet (ElectronJS Framework) - Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2016-1202](https://insights.sbomify.com/CVE-2016-1202/): High severity vulnerability that affects electron (high 7.8)
- [CVE-2017-1000424](https://insights.sbomify.com/CVE-2017-1000424/): Electron vulnerable to URL spoofing via PDFium (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000006 and fix it if it is affected.

What it is: CVE-2018-1000006 is a high-severity command injection vulnerability in n/a, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000006 exists.

Affected packages and fixed versions:
- electron (npm): affected from 1.6.0; fixed in 1.6.16
- electron (npm): affected from 1.6.0; fixed in 1.6.16
- electron (npm): affected from 1.7.0; fixed in 1.7.11
- electron (npm): affected from 1.7.0; fixed in 1.7.11
- electron (npm): affected from 1.8.0; fixed in 1.8.2-beta.4
- electron (npm): affected from 1.8.0; fixed in 1.8.2-beta.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000006/ (Markdown: https://insights.sbomify.com/CVE-2018-1000006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000006
- OSV: https://osv.dev/vulnerability/CVE-2018-1000006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000006/
Summaries are generated and may contain mistakes; the official description above is the record.
