{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:dry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000010 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:dry to 2.50 or later.","what":"CVE-2018-1000010 is a high-severity vulnerability in n/a, published on 23 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000010 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000010 is a high-severity vulnerability in n/a, published on 23 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:dry (Maven): affected all versions; fixed in 2.50\n- org.jvnet.hudson.plugins:dry (Maven): affected all versions; fixed in 2.50\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000010/ (Markdown: https://insights.sbomify.com/CVE-2018-1000010/index.md)","id":"CVE-2018-1000010","markdown":"https://insights.sbomify.com/CVE-2018-1000010/index.md","name":"CVE-2018-1000010","record":{"aliases":["GHSA-x7qf-qh3r-mx22"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins DRY Plugin","requires_auth":"low_privilege","summary":"Attackers with Jenkins user permissions can exploit XML parsing flaws to extract secrets, cause server-side request forgery, or trigger denial-of-service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dry","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins DRY Plugin 2.49 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins DRY Plugin","id":"CVE-2018-1000010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"XML External Entity Reference in Jenkins FindBugs Plugin","id":"CVE-2018-1000011"},"packages":[{"ecosystem":"Maven","fixed":["2.50"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:dry","purl":null,"source":"GHSA-x7qf-qh3r-mx22"},{"ecosystem":"Maven","fixed":["2.50"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:dry","purl":"pkg:maven/org.jvnet.hudson.plugins/dry","source":"GHSA-x7qf-qh3r-mx22"}],"prev":{"headline":"XXE vulnerability in Jenkins Checkstyle Plugin","id":"CVE-2018-1000009"},"products":["n/a"],"published":"2018-01-23","related":[{"cvss_score":5.4,"headline":"Persistent XSS vulnerability in Jenkins DRY Plugin","id":"CVE-2017-1000103","kev_date_added":null,"published":"2017-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers with Jenkins user permissions can exploit XML parsing flaws to extract secrets, cause server-side request forgery, or trigger denial-of-service.","url":"https://insights.sbomify.com/CVE-2018-1000010/"}