{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:warnings. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000012 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:warnings to 4.65 or later.","what":"CVE-2018-1000012 is a high-severity vulnerability in n/a, published on 23 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000012 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000012 is a high-severity vulnerability in n/a, published on 23 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000012 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 4.65\n- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 4.65\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000012/ (Markdown: https://insights.sbomify.com/CVE-2018-1000012/index.md)","id":"CVE-2018-1000012","markdown":"https://insights.sbomify.com/CVE-2018-1000012/index.md","name":"CVE-2018-1000012","record":{"aliases":["GHSA-p498-rpcw-3578"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Warnings Plugin","requires_auth":"low_privilege","summary":"Attackers with Jenkins user permissions can exploit XML parsing flaws to extract secrets, perform SSRF, or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"warnings","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Warnings Plugin 4.64 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability Jenkins Warnings Plugin","id":"CVE-2018-1000012","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"CSRF vulnerability in Jenkins Release plugin","id":"CVE-2018-1000013"},"packages":[{"ecosystem":"Maven","fixed":["4.65"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:warnings","purl":null,"source":"GHSA-p498-rpcw-3578"},{"ecosystem":"Maven","fixed":["4.65"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:warnings","purl":"pkg:maven/org.jvnet.hudson.plugins/warnings","source":"GHSA-p498-rpcw-3578"}],"prev":{"headline":"XML External Entity Reference in Jenkins FindBugs Plugin","id":"CVE-2018-1000011"},"products":["n/a"],"published":"2018-01-23","related":[{"cvss_score":8.8,"headline":"CSRF vulnerability in Jenkins warnings Plugin allows remote code execution","id":"CVE-2020-2280","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":8.8,"headline":"Sandbox Bypass via CSRF in Jenkins Warnings Plugin","id":"CVE-2019-1003007","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":6.5,"headline":"Jenkins Warnings Plugin exposures system-scoped credentials","id":"CVE-2023-46651","kev_date_added":null,"published":"2023-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with Jenkins user permissions can exploit XML parsing flaws to extract secrets, perform SSRF, or cause denial of service.","url":"https://insights.sbomify.com/CVE-2018-1000012/"}