# CVE-2018-1000013: CSRF vulnerability in Jenkins Release plugin

> Attackers can trigger unauthorized release builds in Jenkins via CSRF due to missing POST method enforcement in the Release Plugin.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j2h6-j34w-g5vp

## What is CVE-2018-1000013?

CVE-2018-1000013 is a high-severity vulnerability in n/a, published on 23 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Release Plugin 2.9 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to trigger release builds.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-1000013?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:release. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:release` | Maven | All versions | 2.10 |
| `org.jenkins-ci.plugins:release` | Maven | All versions | 2.10 |

Products: Jenkins Release.

## How do I fix CVE-2018-1000013?

Upgrade org.jenkins-ci.plugins:release to 2.10 or later.

## Is CVE-2018-1000013 being exploited?

There is no known exploitation of CVE-2018-1000013 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-2292](https://insights.sbomify.com/CVE-2020-2292/): Stored XSS vulnerability in Jenkins Release Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000013 and fix it if it is affected.

What it is: CVE-2018-1000013 is a high-severity vulnerability in n/a, published on 23 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000013 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:release (Maven): affected all versions; fixed in 2.10
- org.jenkins-ci.plugins:release (Maven): affected all versions; fixed in 2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000013/ (Markdown: https://insights.sbomify.com/CVE-2018-1000013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000013
- OSV: https://osv.dev/vulnerability/CVE-2018-1000013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000013/
Summaries are generated and may contain mistakes; the official description above is the record.
