{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:translation. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000014 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:translation to 1.16 or later.","what":"CVE-2018-1000014 is a high-severity vulnerability in n/a, published on 23 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000014 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000014 is a high-severity vulnerability in n/a, published on 23 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000014 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:translation (Maven): affected all versions; fixed in 1.16\n- org.jenkins-ci.plugins:translation (Maven): affected all versions; fixed in 1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000014/ (Markdown: https://insights.sbomify.com/CVE-2018-1000014/index.md)","id":"CVE-2018-1000014","markdown":"https://insights.sbomify.com/CVE-2018-1000014/index.md","name":"CVE-2018-1000014","record":{"aliases":["GHSA-pwvj-6phx-qv8c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Attackers can trick Jenkins administrators into overriding localized strings via CSRF, affecting all users on the instance.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"translation_assistance","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Jenkins Translation Assistance Plugin 1.15 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to override localized strings displayed to all users on the current Jenkins instance if the victim is a Jenkins administrator.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Translation Assistance plugin","id":"CVE-2018-1000014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Incorrect permission checks in Pipeline: Nodes and Processes plugin","id":"CVE-2018-1000015"},"packages":[{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:translation","purl":null,"source":"GHSA-pwvj-6phx-qv8c"},{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:translation","purl":"pkg:maven/org.jenkins-ci.plugins/translation","source":"GHSA-pwvj-6phx-qv8c"}],"prev":{"headline":"CSRF vulnerability in Jenkins Release plugin","id":"CVE-2018-1000013"},"products":["n/a"],"published":"2018-01-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can trick Jenkins administrators into overriding localized strings via CSRF, affecting all users on the instance.","url":"https://insights.sbomify.com/CVE-2018-1000014/"}