CVE-2018-1000024 Denial of service in n/a

High 7.5 Published Updated

Remote attackers can cause a denial of service in Squid proxy by sending unusual ESI syntax, affecting all clients using the proxy.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000024?

CVE-2018-1000024 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.

Which versions are affected by CVE-2018-1000024?

It affects 3 products.

Products include Canonical Ubuntu Linux, Debian Debian Linux, Squid-Cache Squid.

How do I fix CVE-2018-1000024?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1000024 being exploited?

There is no known exploitation of CVE-2018-1000024 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2018-1000024, DEBIAN-CVE-2018-1000024, GHSA-gh8j-c69q-gf38, UBUNTU-CVE-2018-1000024.

Is CVE-2018-1000024 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free