# CVE-2018-1000024: Denial of service in n/a

> Remote attackers can cause a denial of service in Squid proxy by sending unusual ESI syntax, affecting all clients using the proxy.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-1000024, DEBIAN-CVE-2018-1000024, GHSA-gh8j-c69q-gf38, UBUNTU-CVE-2018-1000024

## What is CVE-2018-1000024?

CVE-2018-1000024 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.

## Which versions are affected by CVE-2018-1000024?

It affects 3 products.


Products: Canonical Ubuntu Linux, Debian Debian Linux, Squid-Cache Squid.

## How do I fix CVE-2018-1000024?

Upgrade to a fixed version.

## Is CVE-2018-1000024 being exploited?

There is no known exploitation of CVE-2018-1000024 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000024 and fix it if it is affected.

What it is: CVE-2018-1000024 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000024 in the wild and no public exploit code.

Affected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000024/ (Markdown: https://insights.sbomify.com/CVE-2018-1000024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000024
- OSV: https://osv.dev/vulnerability/CVE-2018-1000024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000024/
Summaries are generated and may contain mistakes; the official description above is the record.
