{"answers":{"affected":"2 open source packages ship an affected version, including kreait/firebase-php. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000025 in the wild and no public exploit code.","fix":"Upgrade kreait/firebase-php to 3.8.1 or later.","what":"CVE-2018-1000025 is a high-severity authentication bypass vulnerability in n/a, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000025 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000025 is a high-severity authentication bypass vulnerability in n/a, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kreait/firebase-php (Packagist): affected from 3.2.0; fixed in 3.8.1\n- kreait/firebase-php (Packagist): affected from 3.2.0; fixed in 3.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000025/ (Markdown: https://insights.sbomify.com/CVE-2018-1000025/index.md)","id":"CVE-2018-1000025","markdown":"https://insights.sbomify.com/CVE-2018-1000025/index.md","name":"CVE-2018-1000025","record":{"aliases":["GHSA-4gjj-r7w8-42cq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Firebase Admin SDK","requires_auth":"none","summary":"Attackers can forge JWTs to impersonate users and gain unauthorized access due to missing signature verification in the Firebase Admin SDK for PHP.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"firebase_admin_sdk_for_php","vendor":"firebase_admin_sdk_for_php_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability","id":"CVE-2018-1000025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-1000026"},"packages":[{"ecosystem":"Packagist","fixed":["3.8.1"],"introduced":["3.2.0"],"last_affected":[],"package":"kreait/firebase-php","purl":null,"source":"GHSA-4gjj-r7w8-42cq"},{"ecosystem":"Packagist","fixed":["3.8.1"],"introduced":["3.2.0"],"last_affected":[],"package":"kreait/firebase-php","purl":"pkg:composer/kreait/firebase-php","source":"GHSA-4gjj-r7w8-42cq"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-1000024"},"products":["n/a"],"published":"2018-02-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can forge JWTs to impersonate users and gain unauthorized access due to missing signature verification in the Firebase Admin SDK for PHP.","url":"https://insights.sbomify.com/CVE-2018-1000025/"}