{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:android-lint. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000055 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:android-lint to 2.6 or later.","what":"CVE-2018-1000055 is a high-severity vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000055 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000055 is a high-severity vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000055 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:android-lint (Maven): affected all versions; fixed in 2.6\n- org.jvnet.hudson.plugins:android-lint (Maven): affected all versions; fixed in 2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000055/ (Markdown: https://insights.sbomify.com/CVE-2018-1000055/index.md)","id":"CVE-2018-1000055","markdown":"https://insights.sbomify.com/CVE-2018-1000055/index.md","name":"CVE-2018-1000055","record":{"aliases":["GHSA-3vcx-w94h-68vg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Android Lint Plugin","requires_auth":"low_privilege","summary":"Attackers with Jenkins user permissions can exploit XML external entity processing to extract secrets, perform SSRF, or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"android_lint","vendor":"jenkins"}],"cvss":{"score":8.3,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Android Lint Plugin 2.5 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Android Lint Plugin","id":"CVE-2018-1000055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Improper Restriction of XML External Entity Reference in Jenkins JUnit Plugin","id":"CVE-2018-1000056"},"packages":[{"ecosystem":"Maven","fixed":["2.6"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:android-lint","purl":null,"source":"GHSA-3vcx-w94h-68vg"},{"ecosystem":"Maven","fixed":["2.6"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:android-lint","purl":"pkg:maven/org.jvnet.hudson.plugins/android-lint","source":"GHSA-3vcx-w94h-68vg"}],"prev":{"headline":"Jenkins CCM Plugin vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2018-1000054"},"products":["n/a"],"published":"2018-02-09","related":[{"cvss_score":5.4,"headline":"Stored XSS vulnerability in android-lint Plugin","id":"CVE-2020-2262","kev_date_added":null,"published":"2020-09-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers with Jenkins user permissions can exploit XML external entity processing to extract secrets, perform SSRF, or cause denial of service.","url":"https://insights.sbomify.com/CVE-2018-1000055/"}