# CVE-2018-1000055: XXE vulnerability in Jenkins Android Lint Plugin

> Attackers with Jenkins user permissions can exploit XML external entity processing to extract secrets, perform SSRF, or cause denial of service.

- **Severity:** High 8.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3vcx-w94h-68vg

## What is CVE-2018-1000055?

CVE-2018-1000055 is a high-severity vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Android Lint Plugin 2.5 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-1000055?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:android-lint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:android-lint` | Maven | All versions | 2.6 |
| `org.jvnet.hudson.plugins:android-lint` | Maven | All versions | 2.6 |

Products: Jenkins Android Lint.

## How do I fix CVE-2018-1000055?

Upgrade org.jvnet.hudson.plugins:android-lint to 2.6 or later.

## Is CVE-2018-1000055 being exploited?

There is no known exploitation of CVE-2018-1000055 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-2262](https://insights.sbomify.com/CVE-2020-2262/): Stored XSS vulnerability in android-lint Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000055 and fix it if it is affected.

What it is: CVE-2018-1000055 is a high-severity vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000055 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:android-lint (Maven): affected all versions; fixed in 2.6
- org.jvnet.hudson.plugins:android-lint (Maven): affected all versions; fixed in 2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000055/ (Markdown: https://insights.sbomify.com/CVE-2018-1000055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000055
- OSV: https://osv.dev/vulnerability/CVE-2018-1000055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000055/
Summaries are generated and may contain mistakes; the official description above is the record.
