{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins.workflow:workflow-support. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000058 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins.workflow:workflow-support to 2.18 or later.","what":"CVE-2018-1000058 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000058 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000058 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000058 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins.workflow:workflow-support (Maven): affected all versions; fixed in 2.18\n- org.jenkins-ci.plugins.workflow:workflow-support (Maven): affected all versions; fixed in 2.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000058/ (Markdown: https://insights.sbomify.com/CVE-2018-1000058/index.md)","id":"CVE-2018-1000058","markdown":"https://insights.sbomify.com/CVE-2018-1000058/index.md","name":"CVE-2018-1000058","record":{"aliases":["GHSA-p3g4-9xfv-wq9v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Pipeline plugin","requires_auth":"low_privilege","summary":"Attackers with pipeline configuration permissions can execute arbitrary code via deserialization methods bypassing sandbox protections in Jenkins.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pipeline_supporting_apis","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary code execution due to incomplete sandbox protection in Pipeline: Supporting APIs Plugin","id":"CVE-2018-1000058","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Deserialization in n/a","id":"CVE-2018-1000059"},"packages":[{"ecosystem":"Maven","fixed":["2.18"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins.workflow:workflow-support","purl":null,"source":"GHSA-p3g4-9xfv-wq9v"},{"ecosystem":"Maven","fixed":["2.18"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins.workflow:workflow-support","purl":"pkg:maven/org.jenkins-ci.plugins.workflow/workflow-support","source":"GHSA-p3g4-9xfv-wq9v"}],"prev":{"headline":"Jenkins Credentials Binding Plugin has Insufficiently Protected Credentials","id":"CVE-2018-1000057"},"products":["n/a"],"published":"2018-02-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers with pipeline configuration permissions can execute arbitrary code via deserialization methods bypassing sandbox protections in Jenkins.","url":"https://insights.sbomify.com/CVE-2018-1000058/"}