# CVE-2018-1000058: Arbitrary code execution due to incomplete sandbox protection in Pipeline: Supporting APIs Plugin

> Attackers with pipeline configuration permissions can execute arbitrary code via deserialization methods bypassing sandbox protections in Jenkins.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p3g4-9xfv-wq9v

## What is CVE-2018-1000058?

CVE-2018-1000058 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-1000058?

2 open source packages ship an affected version, including org.jenkins-ci.plugins.workflow:workflow-support. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins.workflow:workflow-support` | Maven | All versions | 2.18 |
| `org.jenkins-ci.plugins.workflow:workflow-support` | Maven | All versions | 2.18 |

Products: Jenkins Pipeline Supporting Apis.

## How do I fix CVE-2018-1000058?

Upgrade org.jenkins-ci.plugins.workflow:workflow-support to 2.18 or later.

## Is CVE-2018-1000058 being exploited?

There is no known exploitation of CVE-2018-1000058 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000058 and fix it if it is affected.

What it is: CVE-2018-1000058 is a high-severity unsafe deserialization vulnerability in n/a, published on 9 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000058 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins.workflow:workflow-support (Maven): affected all versions; fixed in 2.18
- org.jenkins-ci.plugins.workflow:workflow-support (Maven): affected all versions; fixed in 2.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000058/ (Markdown: https://insights.sbomify.com/CVE-2018-1000058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000058
- OSV: https://osv.dev/vulnerability/CVE-2018-1000058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000058/
Summaries are generated and may contain mistakes; the official description above is the record.
