# CVE-2018-1000068: Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

> Attackers can access restricted plugin resource files in Jenkins if the home directory uses a case-insensitive file system.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2018-1000103, GHSA-x6jw-2f23-mc5j

## What is CVE-2018-1000068?

CVE-2018-1000068 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 16 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper input validation vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker to access plugin resource files in the META-INF and WEB-INF directories that should not be accessible, if the Jenkins home directory is on a case-insensitive file system.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1000068?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.89.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.89.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.107 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.107 |

Products: Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2018-1000068?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.89.4 or 2.107.

## Is CVE-2018-1000068 being exploited?

There is no known exploitation of CVE-2018-1000068 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000068 and fix it if it is affected.

What it is: CVE-2018-1000068 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 16 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000068 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.89.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.89.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.107
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.107

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000068/ (Markdown: https://insights.sbomify.com/CVE-2018-1000068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000068
- OSV: https://osv.dev/vulnerability/CVE-2018-1000068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000068/
Summaries are generated and may contain mistakes; the official description above is the record.
