{"answers":{"affected":"4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000073 in the wild and no public exploit code.","fix":"Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.","what":"CVE-2018-1000073 is a high-severity path traversal vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000073 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000073 is a high-severity path traversal vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000073 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000073/ (Markdown: https://insights.sbomify.com/CVE-2018-1000073/index.md)","id":"CVE-2018-1000073","markdown":"https://insights.sbomify.com/CVE-2018-1000073/index.md","name":"CVE-2018-1000073","record":{"aliases":["DEBIAN-CVE-2018-1000073","GHSA-gx69-6cp4-hxrj","UBUNTU-CVE-2018-1000073"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can exploit a directory traversal flaw in RubyGems to write files outside the intended root directory via symlinked base directories.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.","ecosystems":["Maven","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Link Following vulnerability","id":"CVE-2018-1000073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":4,"n_references":14,"next":{"headline":"RubyGems Deserialization of Untrusted Data vulnerability","id":"CVE-2018-1000074"},"packages":[{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":null,"source":"GHSA-gx69-6cp4-hxrj"},{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":"pkg:maven/org.jruby/jruby-stdlib","source":"GHSA-gx69-6cp4-hxrj"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-gx69-6cp4-hxrj"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-gx69-6cp4-hxrj"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-1000072"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":8.3,"headline":"RubyGems allows creation of users with arbitrary unverified emails","id":"CVE-2022-36073","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":7.8,"headline":"RubyGems Deserialization of Untrusted Data vulnerability","id":"CVE-2018-1000074","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.4,"headline":"RubyGems Delete directory using symlink when decompressing tar","id":"CVE-2019-8320","kev_date_added":null,"published":"2019-06-06"},{"cvss_score":5.8,"headline":"RubyGems HTTPS to HTTP redirect","id":"CVE-2012-2125","kev_date_added":null,"published":"2013-10-01"},{"cvss_score":5.5,"headline":"RubyGems Path Traversal vulnerability","id":"CVE-2018-1000079","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.3,"headline":"RubyGems does not verify SSL certificate","id":"CVE-2012-2126","kev_date_added":null,"published":"2013-10-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit a directory traversal flaw in RubyGems to write files outside the intended root directory via symlinked base directories.","url":"https://insights.sbomify.com/CVE-2018-1000073/"}