# CVE-2018-1000073: RubyGems Link Following vulnerability

> Attackers can exploit a directory traversal flaw in RubyGems to write files outside the intended root directory via symlinked base directories.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000073, GHSA-gx69-6cp4-hxrj, UBUNTU-CVE-2018-1000073

## What is CVE-2018-1000073?

CVE-2018-1000073 is a high-severity path traversal vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2018-1000073?

4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |

Products: Rubygems Rubygems.

## How do I fix CVE-2018-1000073?

Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.

## Is CVE-2018-1000073 being exploited?

There is no known exploitation of CVE-2018-1000073 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36073](https://insights.sbomify.com/CVE-2022-36073/): RubyGems allows creation of users with arbitrary unverified emails (high 8.3)
- [CVE-2018-1000074](https://insights.sbomify.com/CVE-2018-1000074/): RubyGems Deserialization of Untrusted Data vulnerability (high 7.8)
- [CVE-2019-8320](https://insights.sbomify.com/CVE-2019-8320/): RubyGems Delete directory using symlink when decompressing tar (high 7.4)
- [CVE-2012-2125](https://insights.sbomify.com/CVE-2012-2125/): RubyGems HTTPS to HTTP redirect (medium 5.8)
- [CVE-2018-1000079](https://insights.sbomify.com/CVE-2018-1000079/): RubyGems Path Traversal vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000073 and fix it if it is affected.

What it is: CVE-2018-1000073 is a high-severity path traversal vulnerability in n/a, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000073 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000073/ (Markdown: https://insights.sbomify.com/CVE-2018-1000073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000073
- OSV: https://osv.dev/vulnerability/CVE-2018-1000073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000073/
Summaries are generated and may contain mistakes; the official description above is the record.
