CVE-2018-1000074 RubyGems Deserialization of Untrusted Data vulnerability
Attackers can execute arbitrary code if a victim runs the gem owner command on a gem with a malicious YAML file.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1000074?
CVE-2018-1000074 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.
Weakness: CWE-502
Which versions are affected by CVE-2018-1000074?
4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
rubygems-update RubyGems | All versions | 2.7.6 |
rubygems-update RubyGems | All versions | 2.7.6 |
Products include Rubygems Rubygems.
How do I fix CVE-2018-1000074?
Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2018-1000074 being exploited?
There is no known exploitation of CVE-2018-1000074 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-36073 RubyGems allows creation of users with arbitrary unverified emails
- CVE-2018-1000073 RubyGems Link Following vulnerability
- CVE-2019-8320 RubyGems Delete directory using symlink when decompressing tar
- CVE-2012-2125 RubyGems HTTPS to HTTP redirect
- CVE-2018-1000079 RubyGems Path Traversal vulnerability
Sources
Also known as DEBIAN-CVE-2018-1000074, DLA-1352-1, GHSA-qj2w-mw2r-pv39, UBUNTU-CVE-2018-1000074, USN-3621-2.