{"answers":{"affected":"4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000074 in the wild and no public exploit code.","fix":"Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.","what":"CVE-2018-1000074 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000074 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000074 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000074 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000074/ (Markdown: https://insights.sbomify.com/CVE-2018-1000074/index.md)","id":"CVE-2018-1000074","markdown":"https://insights.sbomify.com/CVE-2018-1000074/index.md","name":"CVE-2018-1000074","record":{"aliases":["DEBIAN-CVE-2018-1000074","DLA-1352-1","GHSA-qj2w-mw2r-pv39","UBUNTU-CVE-2018-1000074","USN-3621-2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can execute arbitrary code if a victim runs the gem owner command on a gem with a malicious YAML file.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.","ecosystems":["Maven","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Deserialization of Untrusted Data vulnerability","id":"CVE-2018-1000074","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2018"},"n_packages":4,"n_references":18,"next":{"headline":"RubyGems Infinite Loop vulnerability","id":"CVE-2018-1000075"},"packages":[{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":null,"source":"GHSA-qj2w-mw2r-pv39"},{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":"pkg:maven/org.jruby/jruby-stdlib","source":"GHSA-qj2w-mw2r-pv39"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-qj2w-mw2r-pv39"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-qj2w-mw2r-pv39"}],"prev":{"headline":"RubyGems Link Following vulnerability","id":"CVE-2018-1000073"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":8.3,"headline":"RubyGems allows creation of users with arbitrary unverified emails","id":"CVE-2022-36073","kev_date_added":null,"published":"2022-09-07"},{"cvss_score":7.5,"headline":"RubyGems Link Following vulnerability","id":"CVE-2018-1000073","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":7.4,"headline":"RubyGems Delete directory using symlink when decompressing tar","id":"CVE-2019-8320","kev_date_added":null,"published":"2019-06-06"},{"cvss_score":5.8,"headline":"RubyGems HTTPS to HTTP redirect","id":"CVE-2012-2125","kev_date_added":null,"published":"2013-10-01"},{"cvss_score":5.5,"headline":"RubyGems Path Traversal vulnerability","id":"CVE-2018-1000079","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.3,"headline":"RubyGems does not verify SSL certificate","id":"CVE-2012-2126","kev_date_added":null,"published":"2013-10-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code if a victim runs the gem owner command on a gem with a malicious YAML file.","url":"https://insights.sbomify.com/CVE-2018-1000074/"}