# CVE-2018-1000074: RubyGems Deserialization of Untrusted Data vulnerability

> Attackers can execute arbitrary code if a victim runs the gem owner command on a gem with a malicious YAML file.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000074, DLA-1352-1, GHSA-qj2w-mw2r-pv39, UBUNTU-CVE-2018-1000074, USN-3621-2

## What is CVE-2018-1000074?

CVE-2018-1000074 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-1000074?

4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |
| `rubygems-update` | RubyGems | All versions | 2.7.6 |

Products: Rubygems Rubygems.

## How do I fix CVE-2018-1000074?

Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.

## Is CVE-2018-1000074 being exploited?

There is no known exploitation of CVE-2018-1000074 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-36073](https://insights.sbomify.com/CVE-2022-36073/): RubyGems allows creation of users with arbitrary unverified emails (high 8.3)
- [CVE-2018-1000073](https://insights.sbomify.com/CVE-2018-1000073/): RubyGems Link Following vulnerability (high 7.5)
- [CVE-2019-8320](https://insights.sbomify.com/CVE-2019-8320/): RubyGems Delete directory using symlink when decompressing tar (high 7.4)
- [CVE-2012-2125](https://insights.sbomify.com/CVE-2012-2125/): RubyGems HTTPS to HTTP redirect (medium 5.8)
- [CVE-2018-1000079](https://insights.sbomify.com/CVE-2018-1000079/): RubyGems Path Traversal vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000074 and fix it if it is affected.

What it is: CVE-2018-1000074 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000074 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6
- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000074/ (Markdown: https://insights.sbomify.com/CVE-2018-1000074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000074
- OSV: https://osv.dev/vulnerability/CVE-2018-1000074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000074/
Summaries are generated and may contain mistakes; the official description above is the record.
