CVE-2018-1000075 RubyGems Infinite Loop vulnerability
An attacker can cause a denial of service via an infinite loop in RubyGems by providing a tar header with a negative size.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000075?
CVE-2018-1000075 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.
Weakness: CWE-835
Which versions are affected by CVE-2018-1000075?
4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
rubygems-update RubyGems | All versions | 2.7.6 |
rubygems-update RubyGems | All versions | 2.7.6 |
Products include Debian Debian Linux, Rubygems Rubygems.
How do I fix CVE-2018-1000075?
Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2018-1000075 being exploited?
There is no known exploitation of CVE-2018-1000075 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-1000075, GHSA-74pv-v9gh-h25p, UBUNTU-CVE-2018-1000075.