# CVE-2018-1000076: RubyGems Improper Verification of Cryptographic Signature vulnerability

> Attackers can install malicious gems by exploiting improper cryptographic signature verification in RubyGems, leading to potential code execution.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000076, GHSA-mc6j-h948-v2p6, UBUNTU-CVE-2018-1000076

## What is CVE-2018-1000076?

CVE-2018-1000076 is a critical vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2018-1000076?

4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `org.jruby:jruby-stdlib` | Maven | All versions | 9.1.16.0 |
| `rubygems-update` | RubyGems | From 2.2.0 | 2.7.6 |
| `rubygems-update` | RubyGems | From 2.2.0 | 2.7.6 |

Products: Debian Debian Linux, Rubygems Rubygems.

## How do I fix CVE-2018-1000076?

Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.

## Is CVE-2018-1000076 being exploited?

There is no known exploitation of CVE-2018-1000076 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000076 and fix it if it is affected.

What it is: CVE-2018-1000076 is a critical vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000076 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0
- rubygems-update (RubyGems): affected from 2.2.0; fixed in 2.7.6
- rubygems-update (RubyGems): affected from 2.2.0; fixed in 2.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000076/ (Markdown: https://insights.sbomify.com/CVE-2018-1000076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000076
- OSV: https://osv.dev/vulnerability/CVE-2018-1000076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000076/
Summaries are generated and may contain mistakes; the official description above is the record.
