CVE-2018-1000077 RubyGems Improper Input Validation vulnerability
RubyGems allows malicious gems to set invalid homepage URLs due to improper input validation, potentially misleading users or tools.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000077?
CVE-2018-1000077 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.
Weakness: CWE-20
Which versions are affected by CVE-2018-1000077?
4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
org.jruby:jruby-stdlib Maven | All versions | 9.1.16.0 |
rubygems-update RubyGems | All versions | 2.7.6 |
rubygems-update RubyGems | All versions | 2.7.6 |
Products include Debian Debian Linux, Rubygems Rubygems.
How do I fix CVE-2018-1000077?
Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.
Is CVE-2018-1000077 being exploited?
There is no known exploitation of CVE-2018-1000077 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-1000077, GHSA-gv86-43rv-79m2, UBUNTU-CVE-2018-1000077.