{"answers":{"affected":"4 open source packages ship an affected version, including org.jruby:jruby-stdlib and rubygems-update. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-1000077 in the wild and no public exploit code.","fix":"Upgrade org.jruby:jruby-stdlib to 9.1.16.0 or later.","what":"CVE-2018-1000077 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000077 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000077 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000077 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- org.jruby:jruby-stdlib (Maven): affected all versions; fixed in 9.1.16.0\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n- rubygems-update (RubyGems): affected all versions; fixed in 2.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000077/ (Markdown: https://insights.sbomify.com/CVE-2018-1000077/index.md)","id":"CVE-2018-1000077","markdown":"https://insights.sbomify.com/CVE-2018-1000077/index.md","name":"CVE-2018-1000077","record":{"aliases":["DEBIAN-CVE-2018-1000077","GHSA-gv86-43rv-79m2","UBUNTU-CVE-2018-1000077"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"RubyGems allows malicious gems to set invalid homepage URLs due to improper input validation, potentially misleading users or tools.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"rubygems","vendor":"rubygems"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.","ecosystems":["Maven","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems Improper Input Validation vulnerability","id":"CVE-2018-1000077","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"other","year":"2018"},"n_packages":4,"n_references":18,"next":{"headline":"RubyGems Cross-site Scripting vulnerability","id":"CVE-2018-1000078"},"packages":[{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":null,"source":"GHSA-gv86-43rv-79m2"},{"ecosystem":"Maven","fixed":["9.1.16.0"],"introduced":["0"],"last_affected":[],"package":"org.jruby:jruby-stdlib","purl":"pkg:maven/org.jruby/jruby-stdlib","source":"GHSA-gv86-43rv-79m2"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-gv86-43rv-79m2"},{"ecosystem":"RubyGems","fixed":["2.7.6"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-gv86-43rv-79m2"}],"prev":{"headline":"RubyGems Improper Verification of Cryptographic Signature vulnerability","id":"CVE-2018-1000076"},"products":["n/a"],"published":"2018-03-13","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"RubyGems allows malicious gems to set invalid homepage URLs due to improper input validation, potentially misleading users or tools.","url":"https://insights.sbomify.com/CVE-2018-1000077/"}